www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / x11-terms / roxterm / roxterm-3.9.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake xdg-utils
7
8 DESCRIPTION="A terminal emulator designed to integrate with the ROX environment"
9 HOMEPAGE="https://github.com/realh/roxterm"
10 SRC_URI="https://github.com/realh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2 LGPL-3"
13 SLOT="1"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND="dev-libs/dbus-glib
17         dev-libs/glib:2
18         dev-libs/libpcre2
19         sys-apps/dbus
20         x11-libs/gtk+:3
21         x11-libs/vte:2.91[vanilla]"
22 # vanilla vte due to https://github.com/realh/roxterm/issues/222
23 DEPEND="${RDEPEND}
24         dev-libs/libxslt"
25 BDEPEND="virtual/pkgconfig"
26
27 pkg_postinst() {
28         xdg_icon_cache_update
29 }
30
31 pkg_postrm() {
32         xdg_icon_cache_update
33 }