www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / x11-terms / roxterm / roxterm-3.1.5-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python3_6 )
7 inherit gnome2-utils python-any-r1 toolchain-funcs
8
9 DESCRIPTION="A terminal emulator designed to integrate with the ROX environment"
10 HOMEPAGE="http://roxterm.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/roxterm/${P}.tar.xz"
12
13 LICENSE="GPL-2 LGPL-3"
14 SLOT="1"
15 KEYWORDS="amd64 x86"
16 IUSE="nls"
17
18 RDEPEND=">=dev-libs/dbus-glib-0.100
19         dev-libs/glib:2
20         x11-libs/gtk+:3
21         x11-libs/libICE
22         x11-libs/libSM
23         x11-libs/vte:2.91
24         !x11-terms/roxterm:0"
25 # slotted versions of roxterm need block one another due to file collisions. #565288
26 DEPEND="${RDEPEND}
27         ${PYTHON_DEPS}
28         dev-libs/libxslt
29         dev-python/lockfile
30         virtual/pkgconfig
31         virtual/imagemagick-tools
32         nls? ( app-text/po4a sys-devel/gettext )"
33
34 src_configure() {
35         local myconf=(
36                 CC="$(tc-getCC)"
37                 CFLAGS="${CFLAGS}"
38                 LDFLAGS="${LDFLAGS}"
39                 --prefix=/usr
40                 --docdir="/usr/share/doc/${PF}"
41                 --destdir="${D}"
42         )
43
44         use nls || myconf+=( --disable-gettext --disable-po4a --disable-translations )
45         ./mscript.py configure "${myconf[@]}"
46 }
47
48 src_compile() {
49         ./mscript.py build
50 }
51
52 src_install() {
53         ./mscript.py install
54 }
55
56 pkg_preinst() {
57         gnome2_icon_savelist
58 }
59
60 pkg_postinst() {
61         gnome2_icon_cache_update
62 }
63
64 pkg_postrm() {
65         gnome2_icon_cache_update
66 }