*/*: Discontinue Gentoo SuperH port
[gentoo.git] / x11-terms / lilyterm / lilyterm-0.9.9.4-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools
6
7 DESCRIPTION="a terminal emulator based off of libvte that aims to be fast and lightweight"
8 HOMEPAGE="https://lilyterm.luna.com.tw"
9 LICENSE="GPL-3"
10 SRC_URI="https://${PN}.luna.com.tw/file/${P}.tar.gz"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14
15 RDEPEND="
16         x11-libs/vte:0
17 "
18 DEPEND="
19         ${RDEPEND}
20         dev-util/intltool
21         sys-devel/gettext
22         virtual/pkgconfig
23 "
24
25 DOCS=( AUTHORS ChangeLog README TODO )
26 PATCHES=(
27         "${FILESDIR}"/${PN}-0.9.9.4-autogen.patch
28         "${FILESDIR}"/${PN}-0.9.9.4-gettext.patch
29 )
30
31 src_prepare() {
32         default
33
34         ./autogen.sh || die
35         eautoreconf
36 }