x11-terms/xfce4-terminal: arm stable wrt bug #720440
[gentoo.git] / x11-terms / kitty-terminfo / kitty-terminfo-0.17.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit python-any-r1 toolchain-funcs xdg
9
10 DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
11 HOMEPAGE="https://github.com/kovidgoyal/kitty"
12 SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
13 S="${WORKDIR}/kitty-${PV}"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="debug"
19
20 DEPEND="${PYTHON_DEPS}"
21
22 PATCHES=(
23         "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
24 )
25
26 # kitty-terminfo is a split package from kitty that only installs the terminfo
27 # file. As tests are designed to be run with the whole package compiled they
28 # would fail in this case.
29 RESTRICT="test"
30
31 src_compile() {
32         "${EPYTHON}" setup.py \
33                 --verbose $(usex debug --debug "") \
34                 --libdir-name $(get_libdir) \
35                 linux-terminfo || die "Failed to compile kitty."
36 }
37
38 src_install() {
39         insinto /usr
40         doins -r linux-package/*
41 }