6ceb2f1ead77ee88ada66f8167bc2ddf5d7a8c4b
[gentoo.git] / x11-terms / kitty-terminfo / kitty-terminfo-0.16.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit python-single-r1 toolchain-funcs xdg
9
10 DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
11 HOMEPAGE="https://github.com/kovidgoyal/kitty"
12 SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
13 S="${WORKDIR}/kitty-${PV}"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="debug"
19
20 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21
22 RDEPEND="${PYTHON_DEPS}"
23
24 DEPEND="${RDEPEND}"
25
26 PATCHES=(
27         "${FILESDIR}"/kitty-terminfo-setup.patch
28 )
29
30 # kitty-terminfo is a split package from kitty that only installs the terminfo
31 # file. As tests are designed to be run with the whole package compiled they
32 # would fail in this case.
33 RESTRICT="test"
34
35 src_compile() {
36         "${EPYTHON}" setup.py \
37                 --verbose $(usex debug --debug "") \
38                 --libdir-name $(get_libdir) \
39                 linux-terminfo || die "Failed to compile kitty."
40 }
41
42 src_install() {
43         insinto /usr
44         doins -r linux-package/*
45 }