x11-terms/xterm: Version bump 353
[gentoo.git] / x11-terms / guake / guake-3.3.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_6 )
6 DISTUTILS_SINGLE_IMPL=1
7
8 inherit distutils-r1 gnome2-utils xdg-utils
9
10 DESCRIPTION="Drop-down terminal for GNOME"
11 HOMEPAGE="https://github.com/Guake/guake https://pypi.org/project/Guake"
12 SRC_URI="mirror://pypi/G/${PN^}/${P^}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 arm x86"
17 IUSE="utempter"
18
19 RDEPEND="
20         dev-libs/keybinder:3
21         dev-python/dbus-python[${PYTHON_USEDEP}]
22         dev-python/pbr[${PYTHON_USEDEP}]
23         dev-python/pycairo[${PYTHON_USEDEP}]
24         dev-python/pygobject:3[${PYTHON_USEDEP}]
25         x11-libs/libnotify
26         x11-libs/vte:2.91
27         utempter? ( sys-libs/libutempter )
28 "
29 DEPEND="
30         ${RDEPEND}
31         dev-python/setuptools[${PYTHON_USEDEP}]
32         gnome-base/gsettings-desktop-schemas
33         sys-devel/gettext
34         sys-devel/make
35 "
36
37 PATCHES=(
38         "${FILESDIR}"/${PN}-3.3.2-paths.patch
39 )
40 S=${WORKDIR}/${P^}
41
42 python_compile_all() {
43         emake prepare-install prefix=/usr
44         emake generate-paths prefix=/usr DATA_DIR='$(datadir)/guake' DEV_SCHEMA_DIR='$(gsettingsschemadir)'
45         default
46 }
47
48 python_install_all() {
49         emake install-schemas install-locale prefix=/usr DESTDIR="${D}"
50         distutils-r1_python_install_all
51 }
52
53 pkg_postinst() {
54         gnome2_schemas_update
55         xdg_desktop_database_update
56 }
57
58 pkg_postrm() {
59         gnome2_schemas_update
60         xdg_desktop_database_update
61 }