sys-devel/remake: Version bump
[gentoo.git] / x11-terms / eterm / eterm-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools git-r3
6
7 DESCRIPTION="A vt102 terminal emulator for X"
8 HOMEPAGE="http://www.eterm.org/"
9 EGIT_REPO_URI="https://git.enlightenment.org/apps/eterm.git"
10
11 LICENSE="BSD"
12 SLOT="0"
13 IUSE="escreen minimal cpu_flags_x86_mmx cpu_flags_x86_sse2 unicode +utempter"
14
15 RDEPEND="
16         x11-libs/libX11
17         x11-libs/libXt
18         x11-libs/libICE
19         x11-libs/libSM
20         x11-libs/libast
21         media-libs/imlib2[X]
22         media-fonts/font-misc-misc
23         escreen? ( app-misc/screen )
24 "
25 DEPEND="${RDEPEND}"
26
27 DOCS=( ChangeLog README ReleaseNotes bg/README.backgrounds )
28
29 src_prepare() {
30         default
31         eautoreconf
32 }
33
34 src_configure() {
35         export TIC="true"
36         econf \
37                 --disable-static \
38                 $(use_enable escreen) \
39                 --with-imlib \
40                 --enable-trans \
41                 $(use_enable cpu_flags_x86_mmx mmx) \
42                 $(use_enable cpu_flags_x86_sse2 sse2) \
43                 $(use_enable unicode multi-charset) \
44                 $(use_enable utempter utmp) \
45                 --with-delete=execute \
46                 --with-backspace=auto
47 }
48
49 src_install() {
50         use escreen && DOCS+=( doc/README.Escreen )
51         default
52         # We don't install headers to link against this library
53         rm -f "${ED%/}"/usr/*/libEterm.{so,la} || die
54 }