x11-terms/guake: Old
[gentoo.git] / x11-terms / alacritty / alacritty-0.4.0.ebuild
1 # Copyright 2017-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CRATES="
7 adler32-1.0.4
8 aho-corasick-0.6.10
9 aho-corasick-0.7.6
10 andrew-0.2.1
11 android_glue-0.2.3
12 ansi_term-0.11.0
13 approx-0.3.2
14 arc-swap-0.4.4
15 arrayref-0.3.5
16 arrayvec-0.5.1
17 atty-0.2.13
18 autocfg-0.1.7
19 backtrace-0.3.40
20 backtrace-sys-0.1.32
21 base64-0.10.1
22 base64-0.11.0
23 bindgen-0.33.2
24 bitflags-1.2.1
25 blake2b_simd-0.5.9
26 block-0.1.6
27 byteorder-1.3.2
28 bzip2-0.3.3
29 bzip2-sys-0.1.7
30 c2-chacha-0.2.3
31 calloop-0.4.4
32 cc-1.0.47
33 cexpr-0.2.3
34 cfg-if-0.1.9
35 cgl-0.3.2
36 clang-sys-0.22.0
37 clap-2.33.0
38 clipboard-win-2.2.0
39 cloudabi-0.0.3
40 cmake-0.1.42
41 cocoa-0.19.1
42 color_quant-1.0.1
43 constant_time_eq-0.1.4
44 copypasta-0.6.0
45 core-foundation-0.6.4
46 core-foundation-sys-0.6.2
47 core-graphics-0.17.3
48 core-text-13.3.2
49 core-video-sys-0.1.3
50 crc32fast-1.2.0
51 crossbeam-deque-0.7.2
52 crossbeam-epoch-0.8.0
53 crossbeam-queue-0.2.0
54 crossbeam-utils-0.6.6
55 crossbeam-utils-0.7.0
56 deflate-0.7.20
57 dirs-2.0.2
58 dirs-sys-0.3.4
59 dispatch-0.1.4
60 dlib-0.4.1
61 downcast-rs-1.1.1
62 dtoa-0.4.4
63 dunce-1.0.0
64 dwrote-0.9.0
65 either-1.5.3
66 embed-resource-1.3.1
67 env_logger-0.5.13
68 env_logger-0.7.1
69 euclid-0.20.4
70 expat-sys-2.1.6
71 failure-0.1.6
72 failure_derive-0.1.6
73 filetime-0.2.8
74 flate2-1.0.13
75 fnv-1.0.6
76 font-0.1.0
77 foreign-types-0.3.2
78 foreign-types-0.5.0
79 foreign-types-macros-0.2.0
80 foreign-types-shared-0.1.1
81 foreign-types-shared-0.3.0
82 freetype-rs-0.23.0
83 freetype-sys-0.9.0
84 fsevent-0.4.0
85 fsevent-sys-2.0.1
86 fuchsia-cprng-0.1.1
87 fuchsia-zircon-0.3.3
88 fuchsia-zircon-sys-0.3.3
89 getrandom-0.1.13
90 gif-0.10.3
91 gl_generator-0.13.1
92 gl_generator-0.14.0
93 glob-0.2.11
94 hermit-abi-0.1.3
95 http_req-0.5.3
96 humantime-1.3.0
97 idna-0.2.0
98 image-0.22.3
99 inflate-0.4.5
100 inotify-0.6.1
101 inotify-sys-0.1.3
102 instant-0.1.2
103 iovec-0.1.4
104 itoa-0.4.4
105 jobserver-0.1.17
106 jpeg-decoder-0.1.16
107 kernel32-sys-0.2.2
108 khronos_api-3.1.0
109 lazycell-1.2.1
110 lazy_static-1.4.0
111 libc-0.2.65
112 libloading-0.5.2
113 libz-sys-1.0.25
114 line_drawing-0.7.0
115 linked-hash-map-0.5.2
116 lock_api-0.3.1
117 log-0.4.8
118 lzw-0.10.0
119 malloc_buf-0.0.6
120 matches-0.1.8
121 maybe-uninit-2.0.0
122 memchr-1.0.2
123 memchr-2.2.1
124 memmap-0.7.0
125 memoffset-0.5.3
126 miniz_oxide-0.3.5
127 mio-0.6.20
128 mio-anonymous-pipes-0.1.0
129 mio-extras-2.0.5
130 mio-named-pipes-0.1.6
131 miow-0.2.1
132 miow-0.3.3
133 named_pipe-0.4.1
134 native-tls-0.2.3
135 net2-0.2.33
136 nix-0.14.1
137 nix-0.15.0
138 nom-3.2.1
139 nom-4.2.3
140 notify-4.0.14
141 num_cpus-1.11.1
142 num-derive-0.2.5
143 num-integer-0.1.41
144 num-iter-0.1.39
145 num-rational-0.2.2
146 num-traits-0.2.10
147 objc-0.2.7
148 objc-foundation-0.1.1
149 objc_id-0.1.1
150 openssl-0.10.26
151 openssl-probe-0.1.2
152 openssl-sys-0.9.53
153 ordered-float-1.0.2
154 osmesa-sys-0.1.2
155 parking_lot-0.9.0
156 parking_lot-0.10.0
157 parking_lot_core-0.6.2
158 parking_lot_core-0.7.0
159 peeking_take_while-0.1.2
160 percent-encoding-2.1.0
161 phf-0.7.24
162 phf_codegen-0.7.24
163 phf_generator-0.7.24
164 phf_shared-0.7.24
165 pkg-config-0.3.17
166 png-0.15.1
167 podio-0.1.6
168 ppv-lite86-0.2.6
169 proc-macro2-0.4.30
170 proc-macro2-1.0.6
171 quick-error-1.2.2
172 quote-0.3.15
173 quote-0.6.13
174 quote-1.0.2
175 rand-0.6.5
176 rand-0.7.2
177 rand_chacha-0.1.1
178 rand_chacha-0.2.1
179 rand_core-0.3.1
180 rand_core-0.4.2
181 rand_core-0.5.1
182 rand_hc-0.1.0
183 rand_hc-0.2.0
184 rand_isaac-0.1.1
185 rand_jitter-0.1.4
186 rand_os-0.1.3
187 rand_pcg-0.1.2
188 rand_xorshift-0.1.1
189 raw-window-handle-0.3.1
190 rayon-1.2.1
191 rayon-core-1.6.1
192 rdrand-0.4.0
193 redox_syscall-0.1.56
194 redox_users-0.3.1
195 regex-0.2.11
196 regex-1.3.1
197 regex-syntax-0.5.6
198 regex-syntax-0.6.12
199 remove_dir_all-0.5.2
200 rust-argon2-0.5.1
201 rustc-demangle-0.1.16
202 rustc_tools_util-0.2.0
203 rustc_version-0.2.3
204 rusttype-0.7.9
205 rusttype-0.8.2
206 ryu-1.0.2
207 same-file-1.0.5
208 schannel-0.1.16
209 scoped_threadpool-0.1.9
210 scopeguard-1.0.0
211 security-framework-0.3.4
212 security-framework-sys-0.3.3
213 semver-0.9.0
214 semver-parser-0.7.0
215 serde-1.0.102
216 serde_derive-1.0.102
217 serde_json-1.0.41
218 serde_yaml-0.8.11
219 servo-fontconfig-0.4.0
220 servo-fontconfig-sys-4.0.7
221 servo-freetype-sys-4.0.3
222 shared_library-0.1.9
223 signal-hook-0.1.12
224 signal-hook-registry-1.2.0
225 siphasher-0.2.3
226 slab-0.4.2
227 smallvec-0.6.13
228 smallvec-1.0.0
229 smithay-client-toolkit-0.6.4
230 smithay-clipboard-0.3.6
231 socket2-0.3.11
232 spsc-buffer-0.1.1
233 stb_truetype-0.3.1
234 strsim-0.8.0
235 syn-0.15.44
236 syn-1.0.8
237 synstructure-0.12.3
238 tempfile-3.1.0
239 termcolor-1.0.5
240 terminfo-0.6.1
241 textwrap-0.11.0
242 thread_local-0.3.6
243 tiff-0.3.1
244 time-0.1.42
245 ucd-util-0.1.5
246 unicase-2.6.0
247 unicode-bidi-0.3.4
248 unicode-normalization-0.1.11
249 unicode-width-0.1.6
250 unicode-xid-0.1.0
251 unicode-xid-0.2.0
252 url-2.1.0
253 urlocator-0.1.1
254 utf8parse-0.1.1
255 utf8-ranges-1.0.4
256 vcpkg-0.2.7
257 vec_map-0.8.1
258 version_check-0.1.5
259 version_check-0.9.1
260 void-1.0.2
261 vswhom-0.1.0
262 vswhom-sys-0.1.0
263 vte-0.3.3
264 walkdir-2.2.9
265 wasi-0.7.0
266 wayland-client-0.23.6
267 wayland-commons-0.23.6
268 wayland-protocols-0.23.6
269 wayland-scanner-0.23.6
270 wayland-sys-0.23.6
271 which-1.0.5
272 widestring-0.4.0
273 winapi-0.2.8
274 winapi-0.3.8
275 winapi-build-0.1.1
276 winapi-i686-pc-windows-gnu-0.4.0
277 winapi-util-0.1.2
278 winapi-x86_64-pc-windows-gnu-0.4.0
279 wincolor-1.0.2
280 winpty-sys-0.4.3
281 winreg-0.6.2
282 ws2_32-sys-0.2.1
283 x11-clipboard-0.3.3
284 x11-dl-2.18.4
285 xcb-0.8.2
286 xdg-2.2.0
287 xml-rs-0.8.0
288 yaml-rust-0.4.3
289 zip-0.5.3
290 "
291
292 MY_PV="${PV//_rc/-rc}"
293
294 inherit bash-completion-r1 cargo desktop eutils
295
296 DESCRIPTION="GPU-accelerated terminal emulator"
297 HOMEPAGE="https://github.com/jwilm/alacritty"
298
299 if [ ${PV} == "9999" ] ; then
300         inherit git-r3
301         EGIT_REPO_URI="https://github.com/jwilm/alacritty"
302 else
303         SRC_URI="https://github.com/jwilm/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
304         https://dev.gentoo.org/~gyakovlev/distfiles/alacritty_git_deps-${PV}.tar.xz
305         $(cargo_crate_uris ${CRATES})"
306         KEYWORDS="amd64 ppc64"
307 fi
308
309 LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions Boost-1.0 BSD BSD-2 CC0-1.0 FTL ISC MIT MPL-2.0 Unlicense WTFPL-2 ZLIB"
310 SLOT="0"
311 IUSE=""
312
313 DEPEND="
314         media-libs/fontconfig:=
315         media-libs/freetype:2
316         x11-libs/libxcb
317 "
318
319 RDEPEND="${DEPEND}
320         sys-libs/zlib
321         sys-libs/ncurses:0
322         x11-libs/libXcursor
323         x11-libs/libXi
324         x11-libs/libXrandr
325         virtual/opengl
326 "
327
328 BDEPEND="dev-util/cmake
329         >=virtual/rust-1.37.0
330 "
331
332 DOCS=( CHANGELOG.md docs/ansicode.txt INSTALL.md README.md alacritty.yml )
333
334 QA_FLAGS_IGNORED="usr/bin/alacritty"
335
336 S="${WORKDIR}/${PN}-${MY_PV}"
337
338 src_unpack() {
339         if [[ "${PV}" == *9999* ]]; then
340                 git-r3_src_unpack
341                 cargo_live_src_unpack
342         else
343                 cargo_src_unpack
344         fi
345 }
346
347 src_prepare() {
348         [[ "${PV}" == *9999* ]] || ln -s ../alacritty_git_deps "${ECARGO_HOME}"/git
349         default
350 }
351
352 src_install() {
353         CARGO_INSTALL_PATH="alacritty" cargo_src_install
354
355         newbashcomp extra/completions/alacritty.bash alacritty
356
357         insinto /usr/share/fish/vendor_completions.d/
358         doins extra/completions/alacritty.fish
359
360         insinto /usr/share/zsh/site-functions
361         doins extra/completions/_alacritty
362
363         domenu extra/linux/alacritty.desktop
364         newicon extra/logo/alacritty-term.svg Alacritty.svg
365
366         newman extra/alacritty.man alacritty.1
367
368         insinto /usr/share/alacritty/scripts
369         doins -r scripts/*
370
371         einstalldocs
372 }
373
374 src_test() {
375         cargo_src_test --offline
376 }
377
378 pkg_postinst() {
379         optfeature "wayland support" dev-libs/wayland
380         optfeature "apply-tilix-colorscheme script dependency" dev-python/pyyaml
381 }