app-emulation/simh: drop old
[gentoo.git] / x11-plugins / wmsysmon / wmsysmon-0.7.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit toolchain-funcs
6
7 DESCRIPTION="a dockapp to monitor: CPU, Memory, Uptime, IRQs, Paging and Swap activity"
8 HOMEPAGE="https://github.com/voyageur/wmsysmon"
9 SRC_URI="https://github.com/voyageur/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
14 IUSE=""
15
16 DEPEND="x11-libs/libX11
17         x11-libs/libXext
18         x11-libs/libXpm"
19 RDEPEND="${DEPEND}"
20
21 PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
22 DOCS=( ../ChangeLog ../README )
23 S=${WORKDIR}/${P}/src
24
25 src_compile() {
26         emake CC="$(tc-getCC)"
27 }
28
29 src_install() {
30         dobin wmsysmon
31         einstalldocs
32 }