x11-plugins/wmxres: fix build with -fno-common
[gentoo.git] / x11-plugins / wmsmixer / wmsmixer-0.5.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="fork of wmmixer adding scrollwheel support and other features"
9 HOMEPAGE="https://www.dockapps.net/wmsmixer"
10 SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc ppc64 ~sparc x86"
15 IUSE=""
16
17 RDEPEND="x11-libs/libXpm
18         x11-libs/libXext
19         x11-libs/libX11"
20 DEPEND="${RDEPEND}
21         x11-base/xorg-proto"
22
23 src_compile() {
24         $(tc-getCXX) ${CFLAGS} -I/usr/X11R6/include -c -o wmsmixer.o wmsmixer.cc
25         rm -f wmsmixer || die
26         $(tc-getCXX) ${LDFLAGS} -o wmsmixer ${CFLAGS} -L/usr/X11R6/lib wmsmixer.o -lXpm -lXext -lX11
27 }
28
29 src_install() {
30         insinto /usr/bin
31         insopts -m0655
32         doins wmsmixer
33         dodoc README README.wmmixer
34 }