Use https by default
[gentoo.git] / x11-plugins / wmmon / wmmon-1.2_beta1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Dockable system resources monitor applet for WindowMaker"
9 HOMEPAGE="http://repo.or.cz/w/dockapps.git"
10 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P/_beta/b}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
15 IUSE=""
16
17 RDEPEND="x11-libs/libX11
18         x11-libs/libXext
19         x11-libs/libXpm"
20 DEPEND="${RDEPEND}
21         x11-proto/xextproto"
22
23 S=${WORKDIR}/${P/_beta/b}
24
25 src_prepare() {
26         epatch "${FILESDIR}"/${P}-Makefile.patch
27 }
28
29 src_compile() {
30         emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" -C ${PN}
31 }
32
33 src_install () {
34         dobin wmmon/wmmon
35         doman wmmon/wmmon.1
36         dodoc BUGS CHANGES HINTS README TODO
37 }