x11-plugins/wmix: fix build with -fno-common
[gentoo.git] / x11-plugins / wmmemload / wmmemload-0.1.8-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 DESCRIPTION="dockapp that displays memory and swap space usage"
8 HOMEPAGE="https://www.dockapps.net/wmmemload"
9 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 ~ppc ppc64 ~sparc x86"
14
15 RDEPEND="x11-libs/libX11
16         x11-libs/libXext
17         x11-libs/libXpm"
18 DEPEND="${RDEPEND}
19         x11-base/xorg-proto
20         x11-libs/libICE
21         x11-libs/libXt"
22
23 S="${WORKDIR}/dockapps"
24
25 src_prepare() {
26         default
27         eautoreconf
28 }