x11-plugins/wmbinclock: fix build with -fno-common
[gentoo.git] / x11-plugins / wmmaiload / wmmaiload-2.3.0-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit toolchain-funcs
6
7 DESCRIPTION="dockapp that monitors one or more mailboxes"
8 HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
9 SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
14 IUSE=""
15
16 RDEPEND="x11-libs/gtk+:2
17         x11-libs/libXpm"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 PATCHES=( "${FILESDIR}"/${PN}-2.2.1-checkthread.patch )
22 src_prepare() {
23         sed -i -e "s/-lssl/\0 -lcrypto/" wmmaiload/Init.make || die
24         sed -e "s/SSLv2_client_method/SSLv23_client_method/" \
25                 -i wmmaiload/ssl.c || die
26
27         default
28 }
29
30 src_configure() {
31         # The ./configure script is not autoconf based, therefore don't use econf:
32         ./configure -p /usr || die
33 }
34
35 src_compile() {
36         emake \
37                 CC="$(tc-getCC)" \
38                 CFLAGS="${CFLAGS}" \
39                 DEBUG_LDFLAGS="" \
40                 LDFLAGS="${LDFLAGS}" \
41                 DEBUG_CFLAGS=""
42 }
43
44 src_install() {
45         dobin ${PN}/${PN} ${PN}-config/${PN}-config
46         doman doc/*.1
47         dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO doc/sample.${PN}rc
48 }