net-analyzer/wireshark: Version bump (bug #593258).
[gentoo.git] / x11-plugins / wmmaiload / wmmaiload-2.3.0-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 inherit toolchain-funcs
7
8 DESCRIPTION="dockapp that monitors one or more mailboxes"
9 HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
10 SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
15 IUSE=""
16
17 RDEPEND="x11-libs/gtk+:2
18         x11-libs/libXpm"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 PATCHES=( "${FILESDIR}"/${PN}-2.2.1-checkthread.patch )
23 src_prepare() {
24         sed -i -e "s/-lssl/\0 -lcrypto/" wmmaiload/Init.make || die
25         sed -e "s/SSLv2_client_method/SSLv23_client_method/" \
26                 -i wmmaiload/ssl.c || die
27
28         default
29 }
30
31 src_configure() {
32         # The ./configure script is not autoconf based, therefore don't use econf:
33         ./configure -p /usr || die
34 }
35
36 src_compile() {
37         emake \
38                 CC="$(tc-getCC)" \
39                 CFLAGS="${CFLAGS}" \
40                 DEBUG_LDFLAGS="" \
41                 LDFLAGS="${LDFLAGS}" \
42                 DEBUG_CFLAGS=""
43 }
44
45 src_install() {
46         dobin ${PN}/${PN} ${PN}-config/${PN}-config
47         doman doc/*.1
48         dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO doc/sample.${PN}rc
49 }