Use https by default
[gentoo.git] / x11-plugins / wmload / wmload-0.9.6.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="yet another dock application showing a system load gauge"
9 HOMEPAGE="http://windowmaker.org/dockapps/?name=wmload"
10 # Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
11 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
16 IUSE=""
17
18 RDEPEND="x11-libs/libX11
19         x11-libs/libXext
20         x11-libs/libXpm"
21 DEPEND="${RDEPEND}
22         x11-proto/xproto"
23
24 S=${WORKDIR}/dockapps
25
26 src_prepare() {
27         epatch "${FILESDIR}"/${P}-solaris.patch
28 }
29
30 src_compile() {
31         emake CC="$(tc-getCC)"
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
36
37         dodoc README
38         domenu "${FILESDIR}"/${PN}.desktop
39 }