Use https by default
[gentoo.git] / x11-plugins / wmix / wmix-3.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Dockapp mixer for OSS or ALSA"
9 HOMEPAGE="http://windowmaker.org/dockapps/?name=wmix"
10 # Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
11 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
16 IUSE=""
17
18 RDEPEND="x11-libs/libX11
19         x11-libs/libXext
20         x11-libs/libXpm"
21 DEPEND="${RDEPEND}
22         x11-proto/xproto
23         x11-proto/xextproto"
24
25 S=${WORKDIR}/dockapps
26
27 src_compile() {
28         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
29                 LDFLAGS="${LDFLAGS}"
30 }
31
32 src_install() {
33         dobin ${PN}
34         doman "${FILESDIR}"/${PN}.1
35         dodoc AUTHORS BUGS NEWS README sample.wmixrc
36 }