Set appropriate maintainer types in metadata.xml (GLEP 67)
[gentoo.git] / x11-plugins / wmcdplay / wmcdplay-1.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools
7
8 DESCRIPTION="CD player applet for WindowMaker"
9 HOMEPAGE="http://windowmaker.org/dockapps/?name=wmcdplay"
10 # Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
11 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 RDEPEND="x11-libs/libX11
19         x11-libs/libXext
20         x11-libs/libXpm"
21 DEPEND="${RDEPEND}
22         x11-proto/xproto"
23
24 S=${WORKDIR}/dockapps
25
26 src_prepare() {
27         eautoreconf
28 }
29
30 src_install() {
31         emake DESTDIR="${D}" install
32
33         dodoc ARTWORK README
34         domenu "${FILESDIR}"/${PN}.desktop
35 }