Merge remote-tracking branch 'remotes/sbraz/irc'
[gentoo.git] / x11-plugins / wmblob / wmblob-1.0.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools multilib
7
8 DESCRIPTION="a fancy but useless dockapp with moving blobs"
9 HOMEPAGE="http://freshmeat.net/projects/wmblob"
10 SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc sparc x86"
15 IUSE=""
16
17 RDEPEND="x11-libs/gtk+:2
18         x11-libs/libX11
19         x11-libs/libXpm
20         x11-libs/libXext"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23         x11-proto/xextproto
24         x11-libs/libXt"
25
26 DOCS="AUTHORS ChangeLog NEWS README doc/how_it_works"
27
28 src_prepare() {
29         sed -i \
30                 -e "s:-O2:${CFLAGS}:g" \
31                 -e "s:\$x_libraries:/usr/$(get_libdir):" \
32                 configure.ac || die
33
34         eautoreconf
35 }