sys-apps/gawk: stable 5.0.1 for ppc64, bug #725374
[gentoo.git] / x11-plugins / wmSun / wmSun-1.05-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 MY_P=${P/S/s}
8 DESCRIPTION="dockapp which displays the rise/set time of the sun"
9 HOMEPAGE="https://www.dockapps.net/wmsun"
10 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${MY_P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~mips ~ppc ~sparc x86"
15
16 RDEPEND=">=x11-libs/libdockapp-0.7:=
17         x11-libs/libX11
18         x11-libs/libXext
19         x11-libs/libXpm"
20 DEPEND="${RDEPEND}
21         x11-base/xorg-proto"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_compile() {
26         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
27 }
28
29 src_install() {
30         emake DESTDIR="${D}" PREFIX=/usr install
31         dodoc README {BUGS,TODO}
32 }