dev-util/clair: 2.1.3 bump
[gentoo.git] / x11-plugins / pidgin-sipe / pidgin-sipe-1.25.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
7 HOMEPAGE="http://sipe.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13
14 IUSE="dbus debug kerberos ocs2005-message-hack openssl telepathy voice"
15
16 RDEPEND="
17         dev-libs/gmime:2.6
18         dev-libs/libxml2
19         openssl? ( dev-libs/openssl:= )
20         !openssl? ( dev-libs/nss )
21         kerberos? ( virtual/krb5 )
22         voice? (
23                 >=dev-libs/glib-2.28.0
24                 >=net-libs/libnice-0.1.0
25                 media-libs/gstreamer:1.0
26                 net-libs/farstream:0.2
27         )
28         !voice? (
29                 >=dev-libs/glib-2.12.0:2
30         )
31         net-im/pidgin[dbus?]
32         telepathy? (
33                 >=sys-apps/dbus-1.1.0
34                 >=dev-libs/dbus-glib-0.61
35                 >=dev-libs/glib-2.28:2
36                 >=net-libs/telepathy-glib-0.18.0
37         )
38 "
39
40 DEPEND="dev-util/intltool
41         virtual/pkgconfig
42         ${RDEPEND}
43 "
44
45 src_configure() {
46         econf \
47                 --enable-purple \
48                 --disable-quality-check \
49                 $(use_enable telepathy) \
50                 $(use_enable debug) \
51                 $(use_enable ocs2005-message-hack) \
52                 $(use_with dbus) \
53                 $(use_with kerberos krb5) \
54                 $(use_with voice vv) \
55                 $(use_enable !openssl nss) \
56                 $(use_enable openssl)
57 }
58
59 src_install() {
60         emake install DESTDIR="${D}"
61         dodoc AUTHORS ChangeLog NEWS TODO README
62 }