dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-plugins / pidgin-mbpurple / pidgin-mbpurple-0.3.0-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 MY_P="${P/pidgin-/}"
9
10 DESCRIPTION="Pidgin plug-in supporting microblog services like Twitter or identi.ca"
11 HOMEPAGE="https://code.google.com/p/microblog-purple/"
12 SRC_URI="https://microblog-purple.googlecode.com/files/${MY_P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="+twitgin"
18
19 RDEPEND="net-im/pidgin
20         twitgin? ( net-im/pidgin[gtk] )"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23 S=${WORKDIR}/${MY_P}
24
25 src_prepare() {
26         default
27
28         # upstream Issue 226 (Respect LDFLAGS)
29         sed -i "/^LDFLAGS/d" global.mak || die "sed for LDFLAGS failed"
30
31         # upstream Issue 225 (Warnings during compilation using make -j2)
32         sed -i "s/make /\$(MAKE) /g" Makefile || die "sed #2 failed"
33
34         # upstream Issue 224 (configurable twitgin)
35         if ! use twitgin; then
36                 sed -i 's/twitgin//g' Makefile || die
37         fi
38 }
39
40 src_configure() {
41         tc-export CC
42 }