dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-plugins / pidgin-libnotify / pidgin-libnotify-0.14-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="pidgin-libnotify provides popups for pidgin via a libnotify interface"
7 HOMEPAGE="http://gaim-libnotify.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/gaim-libnotify/${P}.tar.gz
9         mirror://debian/pool/main/p/${PN}/${PN}_${PV}-4.debian.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ppc x86"
14 IUSE="nls debug"
15
16 RDEPEND=">=x11-libs/libnotify-0.3.2
17         net-im/pidgin[gtk]
18         x11-libs/gtk+:2"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 PATCHES=(
23         "${WORKDIR}/debian/patches"
24         "${FILESDIR}/${P}-libnotify-0.7.patch"
25 )
26
27 src_prepare() {
28         default
29         sed -i -e '/CFLAGS/s:-g3::' configure || die "sed failed"
30 }
31
32 src_configure() {
33         econf \
34                 --disable-static \
35                 $(use_enable debug) \
36                 $(use_enable nls)
37 }
38
39 src_install() {
40         default
41         find "${D}" -name '*.la' -delete || die "Pruning failed"
42 }