x11-plugins/wmCalClock: fix build with -fno-common
[gentoo.git] / x11-plugins / hexchat-javascript / hexchat-javascript-0.3.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Javascript interface for HexChat"
9 HOMEPAGE="https://github.com/TingPing/hexchat-javascript"
10 SRC_URI="https://github.com/TingPing/hexchat-javascript/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="MPL-2.0"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="examples"
16
17 RDEPEND="
18         dev-lang/spidermonkey:0
19         >=net-irc/hexchat-2.9.6[plugins(+)]"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig"
22
23 pkg_setup() {
24         if [[ ${MERGE_TYPE} != binary ]]; then
25                 tc-export CXX PKG_CONFIG
26         fi
27 }
28
29 src_install() {
30         default
31         if use examples ; then
32                 dodoc -r examples
33         fi
34 }