Replace all herds with appropriate projects (GLEP 67)
[gentoo.git] / x11-plugins / guifications / guifications-2.16.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="2"
6
7 inherit eutils
8
9 MY_PN=pidgin-${PN}
10 MY_PV=${PV/_beta/beta}
11 MY_P=${MY_PN}-${MY_PV}
12 S="${WORKDIR}/${MY_P}"
13 DESCRIPTION="Guifications is a graphical notification plugin for the open source instant message client pidgin"
14 HOMEPAGE="http://plugins.guifications.org/"
15 SRC_URI="http://downloads.guifications.org/plugins//Guifications2/${MY_P}.tar.bz2"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="amd64 hppa ppc sparc x86"
20 IUSE="debug nls"
21
22 RDEPEND="net-im/pidgin[gtk]
23         x11-libs/gtk+:2"
24
25 DEPEND="${DEPEND}
26         virtual/pkgconfig"
27
28 src_configure() {
29         econf \
30                 $(use_enable debug ) \
31                 $(use_enable nls) || die "econf failure"
32 }
33
34 src_install() {
35         emake install DESTDIR="${D}" || die "make install failure"
36         dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION || die
37 }