x11-misc/grub2-theme-preview: Drop old
[gentoo.git] / x11-misc / xvkbd / xvkbd-4.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 DESCRIPTION="virtual keyboard for X window system"
8 HOMEPAGE="http://t-sato.in.coocan.jp/xvkbd/"
9 SRC_URI="http://t-sato.in.coocan.jp/xvkbd/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm ~ppc ~x86"
14
15 RDEPEND="
16         x11-libs/libX11
17         x11-libs/libXaw
18         x11-libs/libXaw3d
19         x11-libs/libXmu
20         x11-libs/libXt
21         x11-libs/libXtst
22 "
23 DEPEND="
24         ${RDEPEND}
25         virtual/pkgconfig
26         x11-base/xorg-proto
27 "
28 PATCHES=(
29         "${FILESDIR}"/${PN}-4.0-destdir.patch
30         "${FILESDIR}"/${PN}-4.0-fno-common.patch
31 )
32
33 src_prepare() {
34         default
35         eautoreconf
36 }
37
38 src_install() {
39         dodir /usr/share/X11/app-defaults
40
41         default
42
43         dodoc ChangeLog README
44         newman ${PN}.man ${PN}.1
45 }