x11-misc/mozo: Version bump to 1.18.0
[gentoo.git] / x11-misc / xsnow / xsnow-1.42-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit toolchain-funcs
6
7 DESCRIPTION="let it snow on your desktop and windows"
8 HOMEPAGE="https://janswaal.home.xs4all.nl/Xsnow/"
9 SRC_URI="${HOMEPAGE}${P}.tar.gz"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="amd64 ppc ppc64 sparc x86 ~x86-fbsd"
14
15 RDEPEND="
16         x11-libs/libX11
17         x11-libs/libXt
18         x11-libs/libXext
19         x11-libs/libXpm
20 "
21 DEPEND="
22         ${RDEPEND}
23         app-text/rman
24         x11-misc/imake
25         x11-misc/gccmakedep
26         x11-proto/xextproto
27         x11-proto/xproto
28 "
29
30 src_compile() {
31         xmkmf || die
32         make depend || die
33         emake \
34                 CC="$(tc-getCC)" \
35                 CDEBUGFLAGS="${CFLAGS}" \
36                 LOCAL_LDFLAGS="${LDFLAGS}"
37 }
38
39 src_install() {
40         dobin xsnow
41         rman -f HTML < xsnow._man > xsnow.1-html || die
42         newman xsnow._man xsnow.1
43         newdoc xsnow.1-html xsnow.1.html
44         dodoc README
45 }