dev-python/routes: keyworded 2.4.1-r1 for ia64, bug #717946
[gentoo.git] / x11-misc / xearth / xearth-1.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils toolchain-funcs
7
8 HOMEPAGE="https://hewgill.com/xearth/original/"
9 DESCRIPTION="Xearth sets the X root window to an image of the Earth"
10 SRC_URI="ftp://cag.lcs.mit.edu/pub/tuna/${P}.tar.gz
11         ftp://ftp.cs.colorado.edu/users/tuna/${P}.tar.gz"
12
13 SLOT="0"
14 LICENSE="xearth"
15 KEYWORDS="~alpha amd64 ppc ppc64 x86"
16 IUSE=""
17
18 RDEPEND="
19         x11-libs/libX11
20         x11-libs/libXext
21         x11-libs/libXt
22 "
23 DEPEND="${RDEPEND}
24         x11-base/xorg-proto
25         x11-misc/imake
26         app-text/rman
27 "
28
29 src_prepare() {
30         epatch "${FILESDIR}"/${P}-include.patch
31 }
32
33 src_configure() {
34         xmkmf || die
35 }
36
37 src_compile() {
38         emake CC=$(tc-getCC) \
39                 CCOPTIONS="${CFLAGS}" \
40                 EXTRA_LDOPTIONS="${LDFLAGS}"
41 }
42
43 src_install() {
44         newman xearth.man xearth.1
45         dobin xearth
46         dodoc BUILT-IN GAMMA-TEST HISTORY README
47 }