x11-misc/grub2-theme-preview: 1.4.2
[gentoo.git] / x11-misc / xdo / xdo-0.5.7.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 DESCRIPTION="Small X utility to perform elementary actions on windows"
8 HOMEPAGE="https://github.com/baskerville/xdo/"
9 SRC_URI="https://github.com/baskerville/xdo/archive/${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="BSD-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14
15 DEPEND="x11-libs/libxcb
16         x11-libs/xcb-util
17         x11-libs/xcb-util-wm"
18 RDEPEND="${DEPEND}"
19
20 src_compile() {
21         emake CC="$(tc-getCC)" PREFIX=/usr
22 }
23
24 src_install() {
25         emake PREFIX=/usr DESTDIR="${D}" install
26 }