dev-python/routes: keyworded 2.4.1-r1 for ia64, bug #717946
[gentoo.git] / x11-misc / xdialog / xdialog-2.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools eutils
7
8 DESCRIPTION="drop-in replacement for cdialog using GTK"
9 HOMEPAGE="http://xdialog.free.fr/"
10 SRC_URI="http://${PN}.free.fr/Xdialog-${PV}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~hppa ppc x86"
15 IUSE="doc examples nls"
16
17 RDEPEND="
18         dev-libs/glib:2
19         >=x11-libs/gtk+-2.2:2
20 "
21 DEPEND="
22         ${RDEPEND}
23         virtual/pkgconfig
24         nls? ( sys-devel/gettext )
25 "
26
27 S="${WORKDIR}/${P/x/X}"
28
29 PATCHES=(
30         "${FILESDIR}"/${P}-{no-strip,install}.patch
31 )
32
33 src_prepare() {
34         epatch "${PATCHES[@]}"
35
36         eautoreconf
37 }
38
39 src_configure() {
40         econf \
41                 $(use_enable nls) \
42                 --with-gtk2
43 }
44
45 src_install() {
46         default
47
48         rm -rv "${D}"/usr/share/doc || die
49
50         dodoc AUTHORS BUGS ChangeLog README
51
52         use doc && dohtml -r doc/
53
54         if use examples; then
55                 insinto "/usr/share/doc/${PF}/examples"
56                 doins samples/*
57         fi
58 }