*/*: update LXQt HOMEPAGE
[gentoo.git] / x11-misc / xdesktopwaves / xdesktopwaves-1.3-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="A cellular automata setting the background of your X Windows desktop under water"
9 HOMEPAGE="http://xdesktopwaves.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11 LICENSE="GPL-2"
12
13 SLOT="0"
14 RDEPEND="x11-libs/libXext"
15 DEPEND="${RDEPEND}
16         x11-base/xorg-proto"
17 KEYWORDS="amd64 ppc x86"
18 IUSE=""
19
20 PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
21
22 src_compile() {
23         tc-export CC
24         emake
25         emake -C xdwapi
26 }
27
28 src_install() {
29         dobin xdesktopwaves xdwapi/xdwapidemo
30         doman xdesktopwaves.1
31         insinto /usr/share/pixmaps
32         doins xdesktopwaves.xpm
33         make_desktop_entry xdesktopwaves
34         einstalldocs
35 }
36
37 pkg_preinst() {
38         elog "To see what xdesktopwaves is able to do, start it by running"
39         elog "'xdesktopwaves' and then run 'xdwapidemo'. You should see the"
40         elog "supported effects on your desktop"
41 }