x11-misc/xsel: arm64 keyworded (bug #721666)
[gentoo.git] / x11-misc / xcape / xcape-1.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
9 HOMEPAGE="https://github.com/alols/xcape"
10 SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
15
16 RDEPEND="x11-libs/libX11
17         x11-libs/libXtst"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
20
21 src_prepare() {
22         # Fix path to man and to pkg-config
23         sed -i \
24                 -e "/MANDIR/s:local:share:" \
25                 -e "s/pkg-config/$(tc-getPKG_CONFIG)/" \
26                 Makefile || die
27
28         epatch_user
29 }
30
31 src_compile() {
32         emake CC="$(tc-getCC)"
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
37 }