dev-libs/tomsfastmath: keyworded 0.13.1 for ia64, bug #725414
[gentoo.git] / x11-misc / unclutter / unclutter-8-r4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Hides mouse pointer while not in use"
9 HOMEPAGE="http://www.ibiblio.org/pub/X11/contrib/utilities/unclutter-8.README"
10 SRC_URI="ftp://ftp.x.org/contrib/utilities/${P}.tar.Z"
11
12 SLOT="0"
13 LICENSE="public-domain"
14 KEYWORDS="~alpha amd64 hppa ~mips ppc ppc64 ~sparc x86"
15
16 RDEPEND="x11-libs/libX11"
17 DEPEND="${RDEPEND}
18         x11-base/xorg-proto"
19
20 S=${WORKDIR}/${PN}
21
22 PATCHES=(
23         "${FILESDIR}"/${P}-include.patch
24         "${FILESDIR}"/${P}-FocusOut.patch
25 )
26
27 src_compile() {
28         emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" LDOPTIONS="${LDFLAGS}"
29 }
30
31 src_install() {
32         dobin unclutter
33         newman unclutter.man unclutter.1x
34         einstalldocs
35 }