x11-misc/snixembed: add new package
[gentoo.git] / x11-misc / tdrop / tdrop-0.3.0.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="WM-Independent Dropdown Creator"
7 HOMEPAGE="https://github.com/noctuid/tdrop"
8
9 if [[ ${PV} == "9999" ]]; then
10         inherit git-r3
11         EGIT_REPO_URI="https://github.com/noctuid/tdrop"
12 else
13         SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
14         KEYWORDS="~amd64 ~ppc64"
15 fi
16
17 LICENSE="BSD-2"
18 SLOT="0"
19 IUSE=""
20
21 RDEPEND="
22         app-shells/bash
23         sys-process/procps
24         x11-apps/xprop
25         x11-apps/xrandr
26         x11-apps/xwininfo
27         x11-misc/xdotool
28 "
29
30 src_compile() {
31         :
32 }
33
34 src_install() {
35         dobin tdrop
36         doman tdrop.1
37         dodoc README.org
38 }