x11-misc/xlockmore: Version 5.63
[gentoo.git] / x11-misc / sw-notify-send / sw-notify-send-1.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 MY_P=tinynotify-send-${PV}
7 DESCRIPTION="A system-wide variant of tinynotify-send"
8 HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
9 SRC_URI="https://github.com/mgorny/tinynotify-send/releases/download/${MY_P}/${MY_P}.tar.bz2"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="x11-libs/libtinynotify:0=
17         ~x11-libs/libtinynotify-cli-${PV}
18         x11-libs/libtinynotify-systemwide:0="
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig"
21
22 DOCS=( README )
23 S=${WORKDIR}/${MY_P}
24
25 src_configure() {
26         local myconf=(
27                 --disable-library
28                 --disable-regular
29                 --enable-system-wide
30         )
31
32         econf "${myconf[@]}"
33 }