x11-misc/xsel: arm64 keyworded (bug #721666)
[gentoo.git] / x11-misc / stalonetray / stalonetray-0.8.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="System tray utility including support for KDE system tray icons"
7 HOMEPAGE="http://stalonetray.sourceforge.net/"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE="debug +graceful-exit kde"
14
15 RDEPEND="x11-libs/libX11
16         x11-libs/libICE
17         x11-libs/libSM
18         x11-libs/libXpm"
19 DEPEND="${RDEPEND}
20         x11-base/xorg-proto"
21
22 src_configure() {
23         econf $(use_enable debug) \
24                 $(use_enable graceful-exit) \
25                 $(use_enable kde native-kde)
26 }
27
28 src_install() {
29         emake DESTDIR="${D}" install
30
31         dodoc AUTHORS ChangeLog NEWS README stalonetrayrc.sample TODO
32         dohtml stalonetray.html
33 }