dev-qt/designer: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-misc / safeeyes / safeeyes-2.0.8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 inherit gnome2-utils xdg distutils-r1
8
9 DESCRIPTION="Linux alternative to EyeLeo"
10 HOMEPAGE="https://github.com/slgobinath/SafeEyes"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 CDEPEND="${PYTHON_DEPS}"
19 DEPEND="${CDEPEND}
20         >=dev-python/setuptools-38.6.0[${PYTHON_USEDEP}]
21         "
22 RDEPEND="${CDEPEND}
23         dev-libs/libappindicator:3
24         dev-python/Babel[${PYTHON_USEDEP}]
25         dev-python/dbus-python[${PYTHON_USEDEP}]
26         dev-python/psutil[${PYTHON_USEDEP}]
27         dev-python/pygobject:3[${PYTHON_USEDEP}]
28         dev-python/python-xlib[${PYTHON_USEDEP}]
29         media-sound/alsa-utils
30         x11-apps/xprop
31         x11-misc/xprintidle
32         "
33
34 DOCS=(
35         README.md
36 )
37
38 pkg_preinst() {
39         gnome2_icon_savelist
40 }
41
42 pkg_postinst() {
43         xdg_desktop_database_update
44         gnome2_icon_cache_update
45 }
46
47 pkg_postrm() {
48         xdg_desktop_database_update
49         gnome2_icon_cache_update
50 }