*/*: update LXQt HOMEPAGE
[gentoo.git] / x11-misc / rodent / rodent-5.3.16.3-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools gnome2-utils xdg-utils
6
7 DESCRIPTION="A fast, small and powerful file manager and graphical shell"
8 HOMEPAGE="http://xffm.org/"
9 SRC_URI="mirror://sourceforge/xffm/${PV}/${P}.tar.bz2"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE=""
15
16 RDEPEND=">=x11-libs/librfm-5.3.16.3"
17 DEPEND="${RDEPEND}
18         dev-util/intltool
19         virtual/pkgconfig"
20
21 DOCS=( AUTHORS ChangeLog TODO )
22
23 src_prepare() {
24         pushd apps/rodent-pkg >/dev/null || die
25         sed -i -e "/^install-data-hook/d" \
26                 -e "/rm -f/d" Build/Makefile.am || die
27         eautoreconf
28         popd >/dev/null || die
29         default
30 }
31
32 pkg_postinst() {
33         gnome2_icon_cache_update
34         xdg_desktop_database_update
35 }
36
37 pkg_postrm() {
38         gnome2_icon_cache_update
39         xdg_desktop_database_update
40 }