dev-python/routes: keyworded 2.4.1-r1 for ia64, bug #717946
[gentoo.git] / x11-misc / qps / qps-2.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake xdg-utils
7
8 DESCRIPTION="Qt GUI Process Manager"
9 HOMEPAGE="https://lxqt.github.io/"
10 SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
11
12 LICENSE="GPL-2 GPL-2+ LGPL-2.1+ QPL-1.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
15
16 BDEPEND="
17         dev-qt/linguist-tools:5
18         >=dev-util/lxqt-build-tools-0.7.0
19 "
20 DEPEND="
21         dev-qt/qtcore:5
22         dev-qt/qtdbus:5
23         dev-qt/qtgui:5
24         dev-qt/qtwidgets:5
25         dev-qt/qtx11extras:5
26 "
27 RDEPEND="${DEPEND}"
28
29 pkg_postinst() {
30         xdg_desktop_database_update
31         xdg_icon_cache_update
32 }
33
34 pkg_postrm() {
35         xdg_desktop_database_update
36         xdg_icon_cache_update
37 }