app-misc/ytree: x86 stable wrt bug #718716
[gentoo.git] / x11-misc / oroborus-keylaunch / oroborus-keylaunch-1.3.9-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN=${PN/oroborus-//}
7
8 DESCRIPTION="utility for binding keys in Oroborus"
9 HOMEPAGE="https://www.oroborus.org"
10 SRC_URI="mirror://debian/pool/main/k/${MY_PN}/${MY_PN}_${PV}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="x11-libs/libX11
18         !x11-wm/oroborus-extras"
19 RDEPEND="${DEPEND}"
20
21 S=${WORKDIR}/${MY_PN}-${PV}
22
23 DOCS=( README docs/example_rc debian/changelog )
24
25 src_prepare() {
26         default
27         sed -e "s: -g -O2 -Wall::" \
28                 -e "/^install:/s/install-docs//" \
29                 -i Makefile.in || die
30 }
31
32 src_compile() {
33         emake VERBOSE=1
34 }