dev-python/cppy: arm64 keyworded (bug #721130)
[gentoo.git] / x11-misc / openbox-menu / openbox-menu-0.8.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="Another dynamic menu generator for Openbox"
8 HOMEPAGE="http://fabrice.thiroux.free.fr/openbox-menu_en.html"
9 SRC_URI="https://bitbucket.org/fabriceT/${PN}/downloads/${P}.tar.bz2"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE="+icons svg"
15 REQUIRED_USE="svg? ( icons )"
16
17 COMMON_DEPEND="
18         dev-libs/glib:2
19         lxde-base/menu-cache
20         x11-libs/gtk+:2
21 "
22 RDEPEND="
23         ${COMMON_DEPEND}
24         icons? ( x11-wm/openbox[imlib,svg?] )
25         !icons? ( x11-wm/openbox )
26 "
27 DEPEND="
28         ${COMMON_DEPEND}
29         virtual/pkgconfig
30 "
31
32 src_prepare() {
33         epatch "${FILESDIR}"/${PN}-0.5.0-build.patch
34         epatch_user
35         tc-export CC PKG_CONFIG
36 }
37
38 src_compile() {
39         emake \
40                 $(usex icons 'ICONS=1' 'ICONS=0') \
41                 $(usex svg 'SVG_ICONS=1' 'SVG_ICONS=0')
42 }