dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / x11-misc / obconf / obconf-2.0.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit xdg-utils
7
8 DESCRIPTION="ObConf is a tool for configuring the Openbox window manager"
9 HOMEPAGE="http://openbox.org/wiki/ObConf:About"
10 SRC_URI="http://openbox.org/dist/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~mips ppc ppc64 sparc x86 ~x86-linux"
15 IUSE="nls"
16
17 RDEPEND="gnome-base/libglade:2.0
18         x11-libs/gtk+:2
19         x11-libs/startup-notification
20         >=x11-wm/openbox-3.5.2"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23         nls? ( sys-devel/gettext )"
24
25 src_configure() {
26         econf \
27                 $(use_enable nls)
28 }
29
30 pkg_postinst() {
31         xdg_desktop_database_update
32         xdg_mimeinfo_database_update
33 }
34
35 pkg_postrm() {
36         xdg_desktop_database_update
37         xdg_mimeinfo_database_update
38 }