x11-misc/birdtray: bump to 1.8.0
[gentoo.git] / x11-misc / nitrogen / nitrogen-1.6.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools flag-o-matic gnome2-utils xdg-utils
6
7 DESCRIPTION="A background browser and setter for X"
8 HOMEPAGE="https://github.com/l3ib/nitrogen"
9 SRC_URI="https://github.com/l3ib/nitrogen/releases/download/${PV}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE="nls xinerama"
15
16 RDEPEND="
17         >=dev-cpp/gtkmm-2.10:2.4
18         >=gnome-base/librsvg-2.20:2
19         >=x11-libs/gtk+-2.10:2
20         xinerama? ( x11-libs/libXinerama )
21 "
22 DEPEND="
23         ${RDEPEND}
24         virtual/pkgconfig
25         nls? ( sys-devel/gettext )
26         xinerama? ( x11-base/xorg-proto )
27 "
28
29 src_prepare() {
30         default
31
32         sed -i -e '/^UPDATE_DESKTOP/s#=.*#= :#g' data/Makefile.am || die
33
34         eautoreconf
35 }
36
37 src_configure() {
38         append-cxxflags -std=c++11
39         econf \
40                 $(use_enable nls) \
41                 $(use_enable xinerama)
42 }
43
44 pkg_postinst() {
45         gnome2_icon_cache_update
46         xdg_desktop_database_update
47 }
48
49 pkg_postrm() {
50         gnome2_icon_cache_update
51         xdg_desktop_database_update
52 }