x11-misc/birdtray: bump to 1.8.0
[gentoo.git] / x11-misc / menumaker / menumaker-0.99.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit autotools python-r1
9
10 DESCRIPTION="Utility that scans through the system and generates a menu of installed programs"
11 HOMEPAGE="http://menumaker.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 ~ppc x86"
17
18 IUSE="doc"
19
20 RDEPEND="${PYTHON_DEPS}"
21 DEPEND="${RDEPEND}
22         doc? ( sys-apps/texinfo )"
23
24 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
25
26 PATCHES=(
27         "${FILESDIR}"/${PN}-0.99.10-AM_PATH_PYTHON.patch
28 )
29
30 src_prepare() {
31         default
32         eautoreconf
33 }
34
35 src_configure() {
36         configure() {
37                 ECONF_SOURCE="${S}" econf PYTHON="${EPYTHON}"
38         }
39         python_foreach_impl run_in_build_dir configure
40 }
41
42 src_compile() {
43         compile() {
44                 default
45                 use doc && emake html
46         }
47         python_foreach_impl run_in_build_dir compile
48 }
49
50 src_install() {
51         compile() {
52                 default
53                 use doc && emake DESTDIR="${D}" install-html
54         }
55         python_foreach_impl run_in_build_dir compile
56         python_replicate_script "${ED%/}"/usr/bin/mmaker
57         einstalldocs
58 }