x11-misc/lightdm-gtk-greeter: amd64 stable wrt bug #724378
[gentoo.git] / x11-misc / lineakd / lineakd-0.9.0-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils ltprune multilib
6
7 MY_P=${P/.0/}
8
9 DESCRIPTION="Linux support for Easy Access and Internet Keyboards"
10 HOMEPAGE="http://lineak.sourceforge.net"
11 SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc sparc x86"
16 IUSE="debug"
17
18 RDEPEND="
19         x11-libs/libICE
20         x11-libs/libSM
21         x11-libs/libX11
22         x11-libs/libXext
23 "
24 DEPEND="
25         ${RDEPEND}
26         x11-base/xorg-proto
27         x11-libs/libxkbfile
28         x11-libs/libXt
29         x11-libs/libXtst
30 "
31
32 S=${WORKDIR}/${MY_P}
33 PATCHES=(
34         "${FILESDIR}"/${P}-gcc43.patch
35         "${FILESDIR}"/${P}-DELL-XPS-M1330-XOrg-1_5.patch
36 )
37
38 src_configure() {
39         econf $(use_enable debug) --with-x
40 }
41
42 src_install() {
43         sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' lineakd/Makefile
44
45         dodir /usr/share/man/man8
46
47         emake -j1 DESTDIR="${D}" install
48
49         prune_libtool_files
50
51         dodoc AUTHORS README TODO
52
53         keepdir /usr/$(get_libdir)/lineakd/plugins
54
55         insinto /etc/lineak
56         doins lineakd.conf.example lineakd.conf.kde.example
57 }