x11-misc/shared-mime-info: 1.15 version bump
[gentoo.git] / x11-misc / ktsuss / ktsuss-2.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="Graphical version of su written in C and GTK+ 2"
9 HOMEPAGE="https://github.com/nomius/ktsuss"
10 SRC_URI="https://github.com/nomius/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="amd64 ~mips ppc ppc64 x86"
15 IUSE="sudo"
16
17 RDEPEND=">=x11-libs/gtk+-2.12.11:2
18         >=dev-libs/glib-2.16.5:2
19         sudo? ( app-admin/sudo )"
20 DEPEND="virtual/pkgconfig
21         ${RDEPEND}"
22
23 DOCS=( Changelog CREDITS README.md )
24
25 src_prepare() {
26         default
27         eautoreconf
28 }
29
30 src_configure() {
31         econf $(use_enable sudo)
32 }