media-plugins/gst-plugins-smoothstreaming: remove old
[gentoo.git] / x11-misc / ipager / ipager-1.1.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A themable desktop pager for fluxbox and other window managers"
7 HOMEPAGE="http://www.useperl.ru/ipager/index.en.html"
8 SRC_URI="http://www.useperl.ru/ipager/src/${P}.tar.gz"
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="xinerama"
14
15 RDEPEND="media-libs/imlib2[X]
16         x11-libs/libXmu
17         xinerama? ( x11-libs/libXinerama )"
18 DEPEND="${RDEPEND}
19         dev-util/scons"
20
21 PATCHES=( "${FILESDIR}/${P}-scons_imlib2.patch"
22           "${FILESDIR}/${P}-scons_flags.patch"
23           "${FILESDIR}/${P}-gcc43.patch"
24           "${FILESDIR}/${P}-gcc47.patch" )
25
26 src_compile() {
27         CONFIG_OPTS="xinerama=false"
28         use xinerama && CONFIG_OPTS="${CONFIG_OPTS} xinerama=true"
29         # FYI: Passing debug=true only adds -ggdb inside the SConstruct
30
31         scons \
32                 --cache-disable \
33                 PREFIX="/usr" \
34                 ${CONFIG_OPTS} \
35                 || die "scons configure failed"
36 }
37
38 src_install() {
39         scons \
40                 --cache-disable \
41                 PREFIX="/usr" \
42                 DESTDIR="${D}" \
43                 install \
44                 || die "scons install failed"
45         dodoc ToDo ChangeLog README
46         dodoc themes/*.conf
47 }