profiles/arch/sparc/package.use.mask: mask g-sorcery[bson]
[gentoo.git] / x11-misc / habak / habak-0.2.5-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 DESCRIPTION="A simple but powerful tool to set desktop wallpaper"
8 HOMEPAGE="https://sourceforge.net/projects/fvwm-crystal/"
9 SRC_URI="https://sourceforge.net/projects/fvwm-crystal/files/${PN}/${PV}/${P}.tar.gz/download -> ${P}-sourceforge.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
14
15 RDEPEND="
16         media-libs/imlib2[X]
17         x11-libs/libX11
18 "
19 DEPEND="
20         ${RDEPEND}
21         virtual/pkgconfig
22         x11-base/xorg-proto
23 "
24 DOCS=( ChangeLog README TODO "${FILESDIR}"/README.en )
25 PATCHES=(
26         "${FILESDIR}"/${P}-fno-common.patch
27         "${FILESDIR}"/${P}-gentoo.patch
28 )
29
30 src_compile() {
31         tc-export CC PKG_CONFIG
32         emake -C src ${PN}
33 }
34
35 src_install() {
36         dobin src/${PN}
37         einstalldocs
38 }