x11-misc/mate-notification-daemon: Stabilize 1.22.1 for amd64,x86
[gentoo.git] / x11-misc / gmrun / gmrun-0.9.2-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools eutils
6
7 DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
8 HOMEPAGE="https://sourceforge.net/projects/gmrun/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-1"
12 SLOT="0"
13 KEYWORDS="amd64 ~mips ppc x86"
14
15 RDEPEND="
16         dev-libs/glib:2
17         dev-libs/popt
18         x11-libs/gtk+:2
19 "
20 DEPEND="
21         ${RDEPEND}
22         elibc_glibc? ( >=sys-libs/glibc-2.10 )
23         sys-apps/sed
24         virtual/pkgconfig
25 "
26
27 src_prepare() {
28         epatch \
29                 "${FILESDIR}"/${P}-gcc43.patch \
30                 "${FILESDIR}"/${P}-sysconfdir.patch \
31                 "${FILESDIR}"/${P}-glibc210.patch \
32                 "${FILESDIR}"/${P}-stlport.patch
33
34         eautoreconf
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" install
39         dodoc AUTHORS ChangeLog README NEWS
40 }