x11-misc/xsel: arm64 keyworded (bug #721666)
[gentoo.git] / x11-misc / gccmakedep / gccmakedep-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="create dependencies in makefiles using 'gcc -M'"
7 HOMEPAGE="https://www.x.org/wiki/ https://gitlab.freedesktop.org/xorg/util/gccmakedep"
8
9 if [[ ${PV} == 9999 ]]; then
10         EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/util/gccmakedep.git"
11         inherit autotools git-r3
12         # x11-misc/util-macros only required on live ebuilds
13         LIVE_DEPEND=">=x11-misc/util-macros-1.18"
14 else
15         SRC_URI="https://www.x.org/releases/individual/util/${P}.tar.bz2"
16         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
17 fi
18
19 LICENSE="MIT"
20 SLOT="0"
21 IUSE=""
22
23 DEPEND="
24         ${LIVE_DEPEND}
25         x11-base/xorg-proto
26 "
27
28 src_prepare() {
29         default
30         [[ ${PV} == 9999 ]] && eautoreconf
31 }
32
33 src_configure() {
34         local econfargs=(
35                 --disable-selective-werror
36         )
37
38         econf "${econfargs[@]}"
39 }