sys-process/audit: Drop old
[gentoo.git] / x11-misc / evolvotron / evolvotron-0.6.2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 PYTHON_DEPEND="2:2.6"
7 inherit python qt4-r2
8
9 DESCRIPTION="Generative art image evolver"
10 HOMEPAGE="https://sourceforge.net/projects/evolvotron/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
16 IUSE=""
17
18 RDEPEND="
19         dev-qt/qtgui:4
20         dev-libs/boost
21 "
22 DEPEND="${RDEPEND}"
23
24 S=${WORKDIR}/${PN}
25
26 pkg_setup() {
27         python_set_active_version 2
28 }
29
30 src_configure() {
31         eqmake4 main.pro
32 }
33
34 src_compile() {
35         ./text_to_markup.py -html < USAGE > evolvotron.html
36         ./text_to_markup.py -qml -s < USAGE > libevolvotron/usage_text.h
37
38         local etsubdir
39         for etsubdir in \
40                 libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate
41                 do
42                 emake sub-${etsubdir}
43         done
44 }
45
46 src_install() {
47         for bin in ${PN}{,_mutate,_render}; do
48                 dobin ${bin}/${bin}
49         done
50
51         doman man/man1/*
52         dodoc BUGS NEWS README TODO USAGE
53         dohtml *.html
54 }